close

Want to keep updated on future dates for this class?

Fill in your details below to follow this event.

What You're Interested In

Thank you! Your submission has been received!

Oops! Something went wrong while submitting the form... give it another shot!

← Back to all classes

ECMAScript 2015 (ES 6) Fundamentals

An intensive bootcamp on the latest version of ECMAScript.

In this one day intensive on ECMAScript 2015 (ES6) Fundamentals, you will learn the about the next version of Javascript - including the many enhancements and features which make Javascript coding easier and more manageable. We will be going over the features of the newest version, and be covering the tools and technologies that will allow you to leverage these features today. 

Some of the things taught will include:

  • Variables and Parameters
  • Classes
  • Functional Programming
  • Built-In Objects
  • Asynchronous Development in ES6
  • Objects in ES6
  • Modules
  • Using ES6 Today

Instructors

What to Bring

Laptop

FAQ

Who will be teaching?

Ryan's worked for Government, Higher Education and startups but it was after his three year stint in Silicon Valley, working for LinkedIn that he unlocked his combined passions of programming and teaching.

Now that he's back in Australia, he's taught the Front-End Web and iOS with Swift Part time courses at General Assembly, as well as running RabbitBird; a small Consultancy focusing on Technology, Coaching and Training.

In this age of seemingly new frameworks every week and new languages every year, it can be hard to sort the signal from the noise. This is what Ryan aims to do, helping individual developers and teams use the best that modern tools and technology have to offer while crafting sustainable and longterm strategies.

WHAT's NEXT?

LOCATION
Collective Campus

1/20 Queen St, Melbourne 3000

SCHEDULE
  • 09:00 AM - 04:00 PM Wednesday, 14 April 2016

COST
ENROL
Enrol

Not sure where to start?

Send us a message with what you're looking for— and we'll get back to you with what you need!